etherFAX Enhances Network Security

In an effort to ensure the highest level of network security and compliance for its customers, etherFAX is disabling support for the 3DES cipher suites, since these are no longer considered secure. The etherFAX service already attempts negotiation with client connections using more secure cipher suites.

For all customers running an etherFAX driver on Windows Server 2008 R2 or Windows 7 and above this change will have NO effect. Customers running legacy operating systems (ie: Windows Server 2003, Windows XP) are encouraged to contact Instant InfoSystems to assist with any impact this change may have on your environment.

More information related to the vulnerability see: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2183

For questions related to this change please contact Instant InfoSystems.